Hestiapi on US boiler

I’ve got a thermostat and boiler with only two wires running up to a thermostat, its got blue and white up to the thermostat but looks like the red is not connected down at the boiler and is cut off at the thermostat. Can I run a wire from the thermostat down to the boiler and connect up the red? The current thermostat has RC and RH bridged and looks to just be battery powered. I’m familiar with electrical work but not sure on what hvac uses for everything. Is there anything i can check with a volt meter to make sure I’m working with the right wires? Since I’ve got the blue and white wires up at the thermostat, do I just need red with voltage up there and in the C R and W ports since this will only be controlling the boiler? I can follow the red and white to what looks like a power cut off in the basement over to the boiler and then those wires branch off to other components like the low water cutoff and some other things, just the red isnt going up to the thermostat but is spliced off to the other components.

From my understanding RC and RH are usually bridged on most thermostats because there is not a seperate “hot” wire coming up from the HVAC (RedHeat) (RedCool) .

Since your wiring seems to be atypical, I would not trust any color guides.

Thermostats basically control closing circuits, so one could assume one of those leading up to your thermostat is a “hot” wire and one is neutral and the thermostat closes this circuit when it wants to run the boiler. I would check those two wires with a volt meter and see if you are getting voltage. (AC)

Do you have any wiring diagram on the boiler or with it (paper)?

If there is no voltage between those two wires, my question would be how does the current thermostat send voltage down one of those wires to turn it “on”?

My current setup with a “typical” HVAC wiring:
Blue (Common/Neutral) -Always closed with red to provide power to raspi via Hestipi power supply
Red (Power/Hot) - provides power to everything
Green(Fan/Neutral) - relay closes to turn on fan (send power to fan circuit)
White(Heat/Neutral) - relay closes to turn on heat (send power to heat circuit)
Yellow(Cool/Neutral) - relay close to turn on cool (send power to cooling circuit)

I’ll post a pic of the diagram on the boiler but it looks like just a pretty basic switch at the thermostat section. Right now i pried away the converter on the board and have the pi powered by the usb port(touch on the screen isnt working but thats another issue) and the blue and white wires in the ports on the board. when I set the heat to auto I do hear a relay click down at the boiler but it does do anything and usually the flames would start up at that point. I read some posts on here about wall wart transformers to provide a separate 24v but seems like usb is powering up the device ok and im fine with it for now. The old thermostat had the r ports jumped with just b and w. like i have this now, and it was battery powered by 2 AAs.

Just checked voltage across the two wires and its reading about 23v across the two pins when heat mode is active. Not sure what else is different because its the exact same two wires that are going to the old thermostat, except on the old thermostat there is a jumper across RC and RH

From looking at it, it seems like having one of those wires in the common and one in white should work for you as you described. This might be another issue. It seems like it should be working, especially since you are hearing something click at the unit.

I had a bad solder/relay somewhere on mine and it would click my heat on but then it would shut off…(I did some code changes and used a different relay and it has been working fine)

For troubleshooting maybe try sticking white in cool(yellow) or fan(green) and turn those on and see if it turns the boiler on and keeps it on.

Cool, I’ll try that next, if that’s literally all they are doing is closing the solid state relay to pass 24v down then im less worried. Wasnt sure what all could burn something up.

Hooked up white to the fan pinout, when setting the fan to on then voltage across the blue and white(g in this case) pins goes from 27v to 24v, and back to 27 when setting fan to off. The relay that is clicking is the gas inlet, I cant tell if its clicking on and off real fast though, i do not hear anything when setting it back to off. i think im going to set the old thermostat back up and take the same readings, will do that tomorrow.

Try this technique.
If your screen is working, focus only on the 4 Pi’s pins that go to the 4 relays.

I tried to reflow the relay pins and doesnt seem to have made a difference, what readings should i be getting on the pinouts across the common and heat/cool/fan pins? Looks like im getting 1.3v and it doesnt change when either of those are turned on or off. I’m also not getting any connectivity when i read resistance.

i was reading the pins wrong, these are the readings from the c/r/w/y/g to pin 6
heat on
c-6 2.1v
r-6 2.1v
w-6 2.1v
y-6 .006v
g-6 2.1v

heat off
c-6 2.1v
r-6 2.1v
w-6 .005v
y-6 .006v
g-6 .005v

Pin 6 is DC ground for the Pi. DC ground is electrically isolated from any of the terminals you measured so the readings you got are practically “zero”.
The relays used are solid state. Which as far as troubleshooting is concerned they have 2 characteristics:

  1. They only conduct AC currents (DC does not pass in any state)
  2. You cannot use an Ohmmeter like you would on an old mechanical (clicky) relay.
    The only test on the relays is to see if 24V AC (note AC!) appears between C and each activated terminal (W, Y, G, W2).

Ok, thanks, will work on that then, I think I misunderstood another post about the EU version

I dont think this is going to work as-is for me because the circuit where the thermostat is its in line with where the low water cut off is, from the boiler wiring diagram in the book it says for an electronic thermostat I need a 24v relay (Honeywell R8222A). This is a Lennox GSB8 boiler. Going to pick up the relay and see if it will work out.

Added this relay today, seems to be doing the trick. Had to rerun the ancient wire back up to the therm to get voltage up there and rewired the lwco to the pressure limit on the active side of the relay and the common to one of the activation side of the relay and the white that goes up to the therm on the other side of the activation terminals of the relay.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.