[SOLVED] HestiaPi Touch US version


#21

Ignore this. It is a service that gives us our public IP and I block any cookies from them.

Can you connect the wires for AC and Fan together on the AC terminal on HestiaPi?
I am not sure if your system has a delay or something for the Fan when it is on AC mode.
I assume the pin assignment on HestiaPi Touch US version is correct, pin 23 is actually connected to the relay where you connect the Fan. You could check with a multimeter if the output of each relay is active (24V AC) when triggered.
You can manually control the state of the 2 relays with this:
https://www.openhab.org/docs/administration/runtime.html
Could the fan relay have died somehow?


#22

The 2 relay clicks are 500msec apart (19:05:07.788 - 19:05:08.224) so not being able to tell them apart is possible


#23

I’m wondering if the fan relay died. I’d love to manually trigger it to test, but I can’t figure out how to do it from the link you sent, sorry. Very very unfamiliar with openhab. I’ll try wiring the cooling & fan pins together. I’ll try to get a tester on the relays, but I have to take off the display to get it off the wall to get to the actual relays, so I’d rather try other testing methods if I can. 500msec sounds right, when the furnace was running over the winter, I heard the double-click of the two, but swear I can only hear one now.

Is there anything to the fact that via the debug output, it shows “ItemCommandEvent” for CoolingPin received ON, and then the “ItemStateChangedEvent” for CoolingPin changed from OFF to ON - but after the “ItemCommandEvent” for FanPin received command ON, there was no subsequent “ItemStateChangedEvent” for FanPin from OFF to ON?


#24

So, I added the line “Switch item=FanMode mappings=[ “ON”=“ON”, “OFF”=“OFF”/, “Schedule”=“SCHEDULE”/]” to default.sitemap, and now I have a switch on the OpenHab BasicUI page. Assuming that’s all I have to do - when I click it on or off, the relay does not react. I get the following results in from the debugger, though:

2019-06-30 11:02:45.435 [ome.event.ItemCommandEvent] - Item ‘FanMode’ received command ON

2019-06-30 11:02:45.619 [vent.ItemStateChangedEvent] - FanMode changed from OFF to ON

2019-06-30 11:02:53.697 [ome.event.ItemCommandEvent] - Item ‘FanMode’ received command OFF

2019-06-30 11:02:53.855 [vent.ItemStateChangedEvent] - FanMode changed from ON to OFF

2019-06-30 11:02:55.454 [ome.event.ItemCommandEvent] - Item ‘FanMode’ received command ON

2019-06-30 11:02:55.602 [vent.ItemStateChangedEvent] - FanMode changed from OFF to ON

2019-06-30 11:03:24.520 [ome.event.ItemCommandEvent] - Item ‘FanMode’ received command OFF

2019-06-30 11:03:24.669 [vent.ItemStateChangedEvent] - FanMode changed from ON to OFF


#25

So, IF what I did should trigger the fan relay on and off, then I think there is something wrong with the relay. Am I correct in assuming it should not matter what pin I have what wire connected to (on the “furnace side” of the relay, not the raspberry pi side of the relay)? Sending the command to turn the fan relay on or off should trigger that on or off, regardless of what is connected to it.


#26

All logs look normal and a faulty relay sounds like the most possible cause.
The relay should trigger even with nothing connected. I am suspecting the relay during testing or something caused a shorting and fused the contacts together on the output side. Or it simply died a few thousand clicks before its time. If you shut HestiaPi down, one simple test is to remove the LCD and measure the voltage with a multimeter between Ground (GND) and the pin for the fan. It should go to 3.3V. If it does and the output of the relay is not 24V AC, then swap the relay with a new one. Its a fairly standard type and you won’t have a problem sorting. One of the reasons why we insist on using common components.


#27

I was thinking about the fact that I had tried rebooting it several times, but not shutting it all the way down. So I did a shutdown via SSH, and as it was shutting down I heard a “clack” of a relay. I booted it back up again, turned on the cooling system, and heard the “click-click” of the two relays turning on. I now have AC! Not sure why, but thought I’d post this in case it helps someone else.


#28

That is weird. Electrically the SoC shouldn’t handle the GPIO’s state differently between a reboot and a shutdown. I don’t like it when a solution magically happens but at least you have it working now.
Closing this thread as it is too long and confusing…


#29