Does hestia-pi-ONE-v1.2-dev work on a Raspberry Pi 4?

I have ran hestia-pi-ONE-v1.2-dev on a Raspberry Pi 2, currently running on a raspberry pi 3 and for testing purposes, and since its what I had laying around, I tried to get it running on a raspberry pi 4 but to no avail. I have it hardwired to the network but it never actually shows up on said network. I have tried two different sd cards, the raspberry pi imager and belena etcher, both on windows(Which has never been a problem for me), and raspberry pi imager on linux which made no difference. I was starting to think that I had a pi with a problem but I popped in an sd card with plain openhabian 3.3 or 3.4 on it and it showed up on the network immediately. Has anyone else ran into this issue?

the date if the OS in the hestia-pi-ONE-v1.2-dev is before Pi 4 was released so I doubt it supports the new hardware which has some major changes. I assume it is a simple update command that is missing for kernel to be able to talk to the new hardware. It is not a HestiaPi/OpenHAB issue.
Googling “update SD for Pi 4” brought this random post that people said worked
https://forums.raspberrypi.com/viewtopic.php?p=1485314&sid=1e76a76f9035fc498edc5f4ec591da43#p1485314
Don’t just run these commands yet. Read more on other results. It is possible you break your setup so make a backup if you have any customisations you don’t want to lose.
Please keep a record of the commands you run and the steps you follow and post them all back here for anyone else who may be interested. I would love a photo or two of your setup, wiring etc out of curiosity.

I’m not trying to convert my current setup, just testing some stuff to try and set one up for a friend, so I shouldn’t have to worry about breaking anything at least! I will post anything I find that works!

Will your friend run it on a Pi 4 or a Zero W ?

I had been figuring on setting them up with a 1 or 2 GB raspberry pi 4, then I can have a hard wired internet connection. I prefer doing that whenever I can. But I can just try and purchase a Raspberry Pi 3 for that purpose as well once they come back into stock somewhere!