Error downloading mvn:org.eclipse.smarthome.binding/org.eclipse.smarthome.binding.mqtt/0.10.0.oh240

I learned of the sunsetting of bintray, followed the instructions there, but still have errors trying to download the MQTT binding (error message is topic title).

Next, I found the legacy openhab addons and copied those to /usr/share/openhab2/addons and changed “remote = true” to “remote = false” in /etc/openhab2/services/addons.cfg.

Still no dice. And yes, I’ve been stopping the openhab service, cleaning the cache then restarting it. This is a fresh install from the image downloaded from HestiaPi Touch ONE v1.1 release

I feel like I’m missing something obvious, but I’ve been banging my head against this for hours and need some sleep. I’m hoping it’s just something simple I’ve overlooked. Perhaps I’ll try the 1.2-dev release

Have you tried this:

Tried that, as per the same instructions at openHAB 2.5.x and the sunset of Bintray - Announcements - openHAB Community. Didn’t seem to work, but now that I’m re-reading the link you provided, it mentions “For hestia-pi-ONE-v1.2-dev images”; I’m going to try dd’ing the 1.2-dev image to the microSD card and see how that goes.

Edit [2022-11-22 Tue 08:28]: Well, that’s progress. The screen at least is showing temperature, humidity and icons for the HVAC. But touch screen isn’t responding (yet). Last line from openhab-cli showlogs is:

[INFO ] [marthome.model.script.initialization] - System is ready to operate, kicking off restored behaviors

Edit [2022-11-22 Tue 10:01]: It’s working now via the OpenHAB app. I’d like to express my gratitude and congratulations on the changes! It’s nice to be able to set the hysteresis from the app, and also have the temperature range bounded instead of just set to heat XOR cool.

I am not seeing a way to close this topic, but should probably leave it open for a few days, even though I consider it closed (for now).

That’s great. Feel free to close it yourself whenever you want or it will close automatically after certain inactivity period.