Going to have to sell my HestiaPi :(

I bought one because I thought I could just have a wifi thermostat that I could display and integrate into the MagicMirror project… as it turns out this is WAY above my pay grade… :frowning:

I just do not have the skill or knowledge to pull it off…

I just wanted to say Thanks for a great idea but winter is here and there’s still no case so I can’t really use it and I have tried and tried to get it connected but no good.

I HATE the idea of having to go with a connected thermostat but I may have to… ughhhh

In the next week we are planning on releasing an MQTT based communication release for the HestiaPi Touch version. This will allow all of these:

  • The local sensor to talk MQTT to the broker (server)
  • The broker to be located either locally (default) or remotely on another machine or even over the internet
  • The broker to easily accept data from any other sensor (client) like in your case

If this helps a bit let me know. I am sorry about the case. I keep my HestiaPi uncased too and the winter is indeed coming so I am in a rush as well to close this very long dragging milestone for the project.

No need to apologise if it’s not ready it’s not ready.

As for the update I’ll hang out a while longer to see how that goes.

Thank you

Sorry for the short answer, I was on my cell… and I HATE typing on that! LOL

The new version sounds like it may make things MUCH easier on my end. Just learning JS so it’s been a struggle and at times I do get in over my head this is clearly one of those times… Everyone keeps telling me “Oh that’s easy”… well it’s been a lot of things…easy not being one of them.

I don’t want to give up on this so I will wait!!!

Again no need to apologize about the case situation I know you want it to be right so you do what you need to do!! :slight_smile:

Is V6 this version that you were talking about?

No :slight_smile:
The MQTT is a major change so it was a good excuse to update the rest of the software too (OH 2.2) as there were some cool features waiting. What happened after the update was a nightmare though so we are still adapting the rest of the system for all the bits to work together in the new versions. Should be ready in a few days…

Sounds awesome… gave me a chance to put the new image on and get wifi working …etc…just practice… :slight_smile:

I just REALLY want this to work… This is just too awesome!

Upgrading AND installing MQTT has been too much for my available time right now.
I tried instead only the MQTT and it worked flawlessly with internal and external MQTT server.
Internal means all messages are received from HestiaPi itself.
External means you can have another machine on the network (local or internet) receiving and processing the messages.

In your case you can have the MagicMirror run the server and receive all messages there (and have HestiaPi subscribed to you to hear about changes) or subscribe MagicMirror to the MQTT server running locally inside HestiaPi.

Either way, as I really want to add the update too in that release, give me a couple of days from next week. If I can’t get the update install properly, I’ll release an new image with MQTT only and the update can wait. :slight_smile:

Good news! We split the 2 tasks of MQTT and upgrading to latest stable version (2.1) and we just finished each separate.
In the next 1-2 days we will put everything together and test the integration is solid with no spin-off bugs introduced.
Expect a major release within the week. :scream:

1 Like

Testing complete and we are very happy! MQTT is changing the scene here enabling lots of new cool stuff to be added.
If you don’t hear from us within the weekend its because the 4GB file is hard to upload from our home line so wait for the Monday upload.

1 Like

Can’t wait… just finally got done with this and got it working… so now hopefully I can integrate the therm into the mirror as well…

Version 7 is released. I know you know it… just posting here too for others to find out :wink:

1 Like

I installed it and changed the network file as per normal but it won’t connect… not sure why. I doubled checked the wpa_supplicant file and it’s correct…suggestions?

if its’s a hidden network you need to uncomment the last line. If it’s not a hidden network you need to leave it commented out:

#       scan_ssid=1

Is the WiFi reception good?

Yes. I’m using AC Router so it will go through walls LOL The therm is sitting in the same room as the router at the moment…

I’ve tried it both ways… not working. OHHHHHHHHHHHHHHHH WAIT…

I should NOT be doing this when I’m tired… I got it… didn’t use my SSID… I used the password there… OMG… LOL

It works.

Do I need to follow the instructions for V6 to get it to show in F? I’ve tried running ./C2F.sh but that’s a no go LOL

I’ll add that in the instructions :wink:
The C2F function should work. Follow the instructions and if it does not work, post here the SSH output.

/home/pi/scripts$ ./F2C.sh
rm: cannot remove ‘/etc/openhab2/sitemaps/default.sitemap’: Permission denied
cp: cannot create regular file ‘/etc/openhab2/sitemaps/default.sitemap’: Permission denied
rm: cannot remove ‘/etc/openhab2/rules/default.rules’: Permission denied
cp: cannot create regular file ‘/etc/openhab2/rules/default.rules’: Permission denied

But after I ran it the temp on the left is in F the right is in C HAHAHA Nice…

The permissions are changed in the latest image so the instructions are updated to support that change. What you described is partly converted to F. Please run again the modified instructions.

1 Like