HestiaPi not loading


#1


Tried installing Hestia pi on a bare bone Raspberry Pi 3 B+ with a 7in touchscreen and a USB dongle mouse keyboard.
Hestia probably keeps getting stuck on first boot at different points starting sound/started wifi/started D something. Each time I waited hours then restarted it loaded a little farther but never started fully… Sceen, mouse and keyboard working. Other OS’s worked(hassos, rpi buster) Is this a known issue using windows with etcher or maybe with RPi 3b+? Is there a good walkthrough for os installation? HELP:)


#2

The ready images on our website have the drivers for the non-HDMI LCD that connects on the GPIO and disable HDMI port. This is the reason you see nothing. I assume everything else is working all this time for you but the screen.
Documentation: Click “Documentation” on our website’s main menu :wink:

Or read through the driver installation steps below and undo the HDMI disabling:
wget http://www.hestiapi.com/download/LCD-show-170703.tar.gz;
tar xvf LCD-show-170703.tar.gz;
cd LCD-show/;
sudo ./LCD35-show;


#3

Thanks for the quick reply. Everything works except for loading GUI interface it gets stuck on loading at the started this or starting that. Last load made it all the way to started D bus (seems to be the furthest it will load)and 3hrs later still hadn’t moved. My 7-inch display works and keyboard also works. I know this because when I control-alt-f4 and go into the config everything works(config,7" screen and mouse and keyboard to navigate). I am also able to watch Hestia as it tries to load from the 7" display. Pretty sure it’s a config issue just not sure exactly.
I have tried the 10.4 and 10.3 install. Same result.
Using Rpi 3 b+/ kuman 7" hdmi to hdmi with micro usb to usb/ wireless keyboard and mouse dongle/ no sensors. Basic setup.
Other installs have always had a walkthrough showing needed changes to get full boot. A dummy guide for the dummy: ) Thanks


#4

I believe this is due to the difference of the hardware (LCD and Pi). HDMI is disabled. If you don’t re-enable it it will only show the first 5-10 sec of the boot sequence (white letters on black background).
Do you get to see the HestiaPi logo (not the Pi logo) and desktop? Please share a picture of the last screen. Due to the many hard reboots the card may be corrupted by the way too.
You never have to wait 3 hours :slight_smile: Within 40-50 seconds you should see the HestiaPi logo and loading countdown.
After ~2 minutes can you detect a “HESTIAPI” SSID WiFi network?


#5

Loading always stops at a blinking_ top left corner on a black background. Able to enter command prompt by using cntrl-alt-delete (display and keyboard work in command line/raspi-config and while loading works) and also through a separate computer using a web browser ip address8080(openhabwebpage) and with putty(ran tests like sudo update upgrade reboot to ensure connection works and it does). Install is running like openhab server no gui interface. Even made changes to the raspu-config like load gui on start and restarted. Same results. Server only no gui. Stays on blinking _ just like openhab2 installation does.

#setting rrecommended by kumam lcd and working on RpiBuster Full and nobs on pi3/4
max_usb_current=1
hdmi_force_hotplug=1
config_hdmi_boost=7
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_drive=1
hdmi_cvt 800 480 60 6 0 0 0
enable_uart=1
dtparam=audio=on
dtparam=i2c_arm=on

#settings recommended hestia
#DMT (computer monitor) modes
#hdmi_group=1
#hdmi_mode=1
#hdmi_drive=2
#dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi
Do I need to switch hdmi to match Hestia recommendations?


#6

Could it be that your display cannot show 480x320 resolution?
As you have SSH access run this for me:

wget http://www.hestiapi.com/download/LCD-show-170703.tar.gz; 
tar xvf LCD-show-170703.tar.gz;
cd LCD-show/;
sudo ./LCD-hdmi

It should disable the SPI LCD and revert back to HDMI.
Let us know of the result.


#7


Too many syntax errors. Still a noob need exact commands and I can copy. Sorry. I have been really good at following directions and understanding what I am reading just not there yet for fixing or writing code/syntax. Hoping to get there soon. I am a work backwards kind of guy. Thanks in advance.


#8

You haven’t connected HestiaPi to your WiFi I suppose.
Please connect to the above mentioned SSID from your phone and follow the prompt on your phone to enter your WiFi details. HestiaPi will then reboot and allow you to repeat the steps. Remember to remove that [ at the beginning of the download URL (I removed it from my reply too - sorry my bad)


#9

First off all thank you. Both solutions you gave where indeed correct. After a couple of rewrites I finally got it some what straight… And it started right up. Have (well had, read on for explanation) a GUI display now with ssh and a visible/accessible web access point(using web browser or Advanced IP Scanner) Looks like having network cable plugged in created some problems. Solution was to create files before loading Hestiapi sd into Raspberry Pi and start it with lan unplugged.(I can show work if anyone interested)
Used Etcher to image Hestia v10-3
Edited config.txt using notepad++ saved to boot directory Hestia
created wpm_ supplicant.conf and saved to boot directory Hestia (Same as setting wifi for pi zero w scenario)
created file named ssh.txt using notepad++ and saved to boot directory Hestia
Install stalled at same blinking _ top left corner. CTRL-ALT-F4 into command line and entered your codes.
sudo wget http://www.hestiapi.com/download/LCD-show-170703.tar.gz;
tar xvf LCD-show-170703.tar.gz;
cd LCD-show/;
sudo ./LCD-hdmi
Rebooted and had it start right into GUI login then GUI. It was glorious. Things were a little laggy with only 4 buttons on screen and able to scroll left and right. So I updated.
CTRL-ALT-F4 and ran sudo apt-get update and upgrade. Process took maybe 30 or so minutes and restarted twice.
Now after logging in I stop at Hestaipi logo with 399 sec count down with wifi ip and wifi mac address showing
Then a pop-up at end of counter that says.

This page says
SecurityError: Blocked a frame with origin"file://" from accessing a cross-origin frame
Press ok button and the 399 sec count down restarts…

No ssh and no visible web login. I can still CTRL-ALT-F4 into command prompt.
I am sooo close:)


#10

Please follow this first to connect to the WiFi correctly.


When all is good, you should not be seeing the additional WiFi network.