HestiaPi Touchscreen Blank (White)


#1

Well I finally got my PCB assembled and through many trials I was able to get it to power up! I had some trouble trying to figure out the line voltage but was able to isolate my issue. I fried the two transistors. The pi seems to power up but my touch screen remains white. Any ideas on what to try to get that working? I have the latest version of the HestiaPi image installed on my flash disk.

Any help is greatly appreciated! This has been a very fun build. I will post some pics once I get things working. I ran into a few minor issues 3D printing the case as well but I was able to have a student (I work at a school) help me with it. I’ll post details in my next update. :slight_smile:

Cheers!

Joe


#2

I did read the install instructions and saw that the screen had to power up before / with the pi. I am re-flashing my flash disk and trying that out.


#3

Did reflashing solve the problem?
Is the green LED on the RasPi blinking on boot like it is reading data from the SD or is it solid ON or OFF?
Is the LCD pushed firmly all the way in?


#4

Hi!

I am experiencing the same problem, I have a constant white screen, even if I press the reset button. My HestiaPi seems to boot the base Linux OS at least, as it connects to my WPA just fine and I am able to SSH, netstat -tunapl shows a bunch of userspace openhab processes listening on TCP/8080 and so on

@mountbaldy where you able to fix this by reflashing the SD card?

@HestiaPi I will proceed with the reflash if there are no news from fellow members of the forum, however, as I have a system I can SSH, it would be handy to know if there is some way to reinitialize just the display, ot at least emulate a first time display initialization routines thay may probably occur on the first boot. As opposed to flashing and starting from scratch…


#5

Regarding the TCP/8080, the browser pointing at them only gets 404.

Thank you!!


#6

I have reflashed with latest 9.2, still white LCD, however, now I can browse TCP/8080 just fine and trigger the relays from the basic web openhab.

I tried by pressing reset and exerting pressure on the LCD header connection, but nothing, does pressing the reset button cuts all the power from the Pi? I have read that it has to be initialized on power up, and I wonder if that is the problem, that my installation does not cut the power …

The Water relay triggers and sounds just like a normal relay, the Heating relay does not sound, instead, all I can hear is just a weak scratchy noise…

Thank you very much!

Cheers,
Antonio


#7

Hmmm… a few pointers…
About the LCD, try powering it up without the top cover so you can clearly contol where the LCD sits. Press it all the way in so that the black parts of both the LCD and board’s connectors touch. Also make sure it is aligned correctly. Pin 1 of the LCD to pin 1 of the RasPi.
The fact that you were getting 404 means that you either tried it before the HestiaPi hasn’t completed starting all services or that the card got corrupted with too many power connections/disconnections during the first seconds of its booting process.
The reset switch forces a hard reset on the RasPi. The power to the LCD still remains. The initialisation of the LCD only occurs on boot time so you cannot re-force it later. If things are good, after ~10sec of powering up you will see the boot messages on the screen before the desktop starts. All units are fully tested before shipping, so was yours. Double check my above points and let us know please.


#8

Hi!

The LCD is alligned correctly, and still nothing… I’m slapped!

I have reflashed with dd again the latest image (md5 checksum is correct) and confirm that the display is still white, the flashing went well as I can enumerate the two partitions and access /etc in the rootfs to setup WPA, the system boots fine, I can SSH.

I start to believe that the display came broken, I know you doublecheck, so it is very rare.

Thank you very much for your help.

Best regards,
Antonio


#9

My problem became a bit bigger. My board was my experimental board. I had some troubles gertting my RPi mounted correctly and wore off the copper on my board. Needless to say the connections I had were horrible. I was not making a connection to all of the header pins. I ended up ordering some pre-made PCB’s from China. I imagine I’ll see them here in a few weeks.

The process of creating my own was still worthwhile! I believe the quality of my PCB blanks were not very good as many of the traces were coming off during the soldering process. I also had to solder in wire in order to make my pass thru connections to the other side of the board.

Another casualty of this process was my screen. I ended up pushing too hard and cracking it. This was totally my fault. That is why it has taken me so long to update.

@antx Good luck with your project!

Cheers,

Joe


#10

@antx
I guess this is the case, but I just want to make sure, so could you please confirm that you test the above while powered from a standard wall outlet?
In the case of undervoltage the LCD may give up on showing the image and turn white…
Could you also check if the brown ribon cable on the side of the LCD is not damaged/bent/cut?
If it is indeed faulty a replacement will be resent :slight_smile: PMing you…


#11

We could have sent you a blank PCB from EU. You’ve proven yourself eligible for a freebie :wink:
Can you cancel the Chinese order?


#12

Boy I just saw this. I sure do appreciate it!

So I’m back to the forum. I got my PCB’s in and they are amazing! The company I used did a great job. Now I have some more I can make for my family. :smile:

I got everything re-soldered and put back together. I booted things up for the first time and got a root account locked message. I re-imaged my SD Card with the image I had downloaded for version 2.0 and I’m back to a white screen.

Note, the first time I booted things up I had a white screen for quite some time before the shell appeared.

Let me know your thoughts!

When I"m all done I’ll post some notes and updates. Having the professionally made PCB made things way way simpler!

Cheers!


#13

Update!

I discovered my error… I was working on setting up OpenHAB a few weeks ago and had the image for that downloaded and accidentally installed that on my card instead of HestiaPi. :smile: I downloaded version 8 from the website and we boot up! I am going to re-download version 9, re-image my card and try again tonight. I’m sure it will work.

Thanks again!

Cheers!


#14

The white screen appears for about 10 sec on first boot but obviously your case was wrong image :wink:
Glad you figured it out.
If the SSH credentials are not pi/hestia then you are on another image. :slight_smile:
9.2 is (currently) the latest image.
Have fun and let us know if you get stuck somewhere


#15

We have HestiaPi running! :smile: After a few minor adjustments I have it up and going. I had to change from C to F and I had my BME sensor data wires incorrect but with minor adjustments we’re up and going! Now it’s time to play with the interface. Than wait until we get things setup in the new house.

I have not tested the relays yet but I’m sure they work well. I’ll have an extensive write up for you here in no time as well.

Thanks for all of your help! I am going to be showing this off to my advanced computers class here next week.

Cheers!