Howto adjust brightness

I just set my brand new HestiaPi in the living room, looks great!

One thing I would like to tweak is brightness. It is lightening all the corridor!

Do you know a way to adjust the LCD backlight?

I’m afraid the LCD does not support that. The power used for the backlight is shared with the electronics so you cannot cut or limit it without breaking communication with the Pi.
A hack I found but requires a bit of electronics is here:


It adjusts the brightness according to ambient light of the room, which is probably exactly what you are after.

What about doing it in software? Rather than sending a backlight dim command to the display you could manipulate the image itself that you send to the LCD using a command line tool like xrandr.

xrandr --brightness .8

I haven’t tested it myself but can try it out next time I have a free afternoon, unless someone else wants to give it a shot first.

As the actual light of the backlight is not accessible from software the most you can do is make the image shown more black which is what you are suggesting. I don’t think this will affect much as the UI is already black enough.
As a quick test you could make a completely black html page in the ~/scripts folder and load this instead of the UI.

If this is OK for you you can enable the screensaver like so:
sudo nano /etc/lightdm/lightdm.conf
find and modify the xserver-command line under [Seat:*] to this:
xserver-command=X -nocursor

Cannot remember where you set the timeout. I don’t have access on a HestiaPi instance from where I am now but this should be a google search away.

I get this:

pi@raspberrypi:~ $ xrandr --brightness .8
xrandr: --brightness must be used after --output
Try 'xrandr --help' for more information.

Now i just tested it in vbox and not on my Pi but to get the xrandr command to work, try the following and let me know if it works:

xrandr --current

should output something like so:

Where I have highlighted, you will want to use that as the output. So in my case, it would be:

xrandr --output Virtual1 --brightness .8

I trued that command and get “Can’t open display” as a result.

I don’t have the info handy right now, but this is something we tried very hard before giving up due to the limitation of the hardware. More expensive LCDs can do the trick much easier as they simply timeout from the OS like a screensaver.

pi@raspberrypi:~ $ DISPLAY=:0 xrandr --current
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 480 x 320, current 480 x 320, maximum 480 x 320
default connected 480x320+0+0 0mm x 0mm
   480x320        0.00* 
pi@raspberrypi:~ $ DISPLAY=:0 xrandr --output default --brightness .8
xrandr: Gamma size is 0.