Iothermostat web server not working


#1

HI
I have installed the iothermostat sw on HestiaPi Touch ONE following all the instruction, but the web interface is not reachable.
Any info?

Thank you


#2

Please notify the iothermostat developer with the @ symbol followed by their username in your question.


#3

Hi,

I saw your PM, thanks, and let’s keep this public for everyones benefit.

What URL do you use to access the web interface?

Can you ssh into the system?

If so, could you post the output of 'systemctl status lighttpd.service’ ?

And if that doesn’t show anything of interest, could you post the output of ‘journalctl -r -b’ (best just after a reboot, to keep it as short as necessary)?


#4

Hi Jan
we have done some debug, and found something:

  1. Now web interface is reachable at URL: http://192.168.50.142/iothermostat/ # we have modified the file /etc/lighttpd/conf.d/redirect.conf changing IP in this line $HTTP[“remoteip”] !~ “192.168.50.|127.0.0.1” { I suppose that in the configuration phase is need to ask for the local network configuration or get the correct net from wifi config
  2. on the screen device do not appear the scheduling button
  3. on the web interface the scheduling button appear aside the home button after you press I button
  4. on web interface there is no way to exit the scheduling page, unless you use the back button of the browser
  5. on web interface if you select scheduling without setting any scheduling and go back using the browser the IOThermostat service crash, is need to tart the service manually
  6. the luminosity of the screen device, even in standby, during the night is too much strong

Our next step will be to configure an OpenHub server to connect to HetiaPI, we believe that you sw is more quicker than the HestiPI (which is very nice in any case) sw with Openhub, but need some improvement.

Ciao
Sergio


#5

Hi Sergio,

  1. Good observation. The redirect.conf assumes 192.168.1.* to be local, if your visiting pc has a different IP range it will be redirected to https. If that is not configured, it will not work. If you don’t use https at all, you could comment out in lighttpd.conf the line saying: include "conf.d/redirect.conf"
  2. Scheduling GUI was left out intentionally from the device itself. It’s a feature on the remote web interface :slight_smile:
  3. As intended orginally, but one could add a button if HTML savvy
  4. Same as 3
  5. Not intended to behave like that! I suspect the python code receives an empty schedulestring but doesn;t know how to handle it. But to be sure I’d need to reproduce this, or receive detailed logs. Try this: in heaterscheduler.py, after line 202 rows = [] add:
if not schedulestring:
    # empty string returns nothing
    return None
  1. It’s the only brightness the hardware can do unfortunately.