Relay always open (DIY installation)


First of all thank you for the project HestiaPi!

I started a small DIY montage.
However, I have a problem with the control of the heating relay: the latter remains permanently open (no matter whether the chosen option is Off or the temperature setpoint is exceeded)

I am using the EU version of HestiaPi 10.4 on a Raspberrypi zero W.
The “IN” input of the relay is connected to the GPIO23 pin (for the rest it’s a 5V relay).

Everything works well (sensor, interface, etc …).
No abnormal logs for OpenHab.
And the relay is functional (I can control it manually via the GPIO zero library).
I also tried a clean installation.

Am I missing something?

Have you checked the transistor’s input signal and output when triggered and not triggered? It could be a dead one.

Thanks for your answer :slight_smile:

I’m using a 5v relay like these one :

The relay is directly connected to GPIO pin, no transistor between.

I assume the relay board is expecting 5V but the Pi can only output 3.3V. Please disconnect the Pi and test with a 5V source if it triggers it

The issue seems sofware related since the relay works if i manually send command (using GPIO Zero library)

Have you tried rebooting? Maybe the pin is locked from previous tests with sudo or similar. Or the user who runs openHAB is not in the gpio group and cannot control. Did you modify the provided image file afterwards?
Send some pictures of the PCB and the wiring if the above don’t help.

I’ve just tried on a fresh install (i’ve just set up the wifi), same issue.

pi user is in the gpio group :

Here is the PCB and wiring :

Did you try our image file or a raspbian image?

I would also suggest connecting the relay to Pin 12 instead and use the UI to control hot water. This leaves setpoints and the sensor value out of the equation for testing purposes.

I’ve finally find the problem !

Thanks you for your help and your suggest of using pin 12.

In fact some pin (at lest 16, 18, 32, and 36) of my rpi zero deliver abnormal voltage in low state (from 2,3 to 2,82V…).
And it’s sufficient to permanently trigger the used relay (3,3V triggered relay).

Of course all pin i’ve used for test purpose were defectives <_<
All is fine with another rpi.

Thanks you again !