Reversing GPIO HIGH LOW


#1

Pretty new to Hestiapi and OpenHab for that matter. I think this issue may reside in OpenHab, but I am pretty new there too.

I sourced my own parts and put it together ( I didn’t want to wait until the end of the year :P) Everything is working fine, however my switches are backwards (On = off and off = on) and I am pretty sure it has to do with the SSRs I have. Should be a simple fix of reversing the GPIO high/low, but I do not know where to do that. In the bindings somewhere? I will continue to dig, but any insight would be much appreciated.

Thanks


#2

I really don’t recommend that change. If Pi freezes or reboots and never comes back (corrupted SD) your heating will stay on forever! Please consider sourcing the right components.


#3

Makes total sense, but in the interest of my own troubleshooting in the interim, can I get this location?


#4

Oh and to put everyone’s mind at ease, I sourced the proper high level trigger relays today :slight_smile:


#5

It seems you can change the items file:

like this:
sudo nano /etc/openhab2/items/default.items

and play with this flag:

[activelow:yes|no]

See full documentation here.

Please report here if you make it but re-include my warning as people tend to skim to the answer and copy-paste and run!