Screen not coming on, no temp reading


#1

Hi forum,

So, having thought I was getting the measure of this thing, I decided to try and put the cover on it. I took the screen off thinking it’d probably be like VGA or HDMI, and be hot pluggable? It didn’t work once I plugged it back on with it inside the cover clips.

Wose still, in my ham fisted effort to get the cover on, the bottom clip broke (oh well, not the end of the world) and the fly lead going to the temperature element snapped a pin at the bottom (brown).

It switched it off at the mains, it booted, needed another fsck, booted it again, now it shows everything right up until I should see the actual Hestia UI, and it’s just a black lit up box. I see boot text, the Rasberry PI desktop, the WIFI details, just not the actual UI.

I can still use the app, but it says the temperature is dash, or - :frowning:

Any ideas how to restore the UI screen?

Any ideas how to fix that snapped pin? Solder? By a new crimp thing?


#2

Oh, dear… yes you definitely need to solder that pin back.
Cut the power, finish your soldering, attach LCD to the cover, put the cover on and then restore power.

The LCD is surely not hot pluggable and also HestiaPi reboots when reconnected so that it is initialised (at boot time only).
If you finish above steps and still face the same issue even after 20 minutes, I would advise to follow these steps

Visit http://[RasPi_IP]:8080
Click on HABPANEL
Click on the burger menu (the three dashes) on the top left corner
Click on the gear icon bottom left next to the clock
Select “Panel configuration: Server Storage”
Press OK on the popup
Click on the burger menu again on the top left corner
Choose HESTIAPI

If you can’t see the UI there either I would suggest something is corrupted on the UI files.


#3

Hi mate, never done these connectors before. It snapped at the side that goes on the Pi. These appear to be called Dupont connectors?

Any idea what sort I would want for this end, and what’s my chances of mangling one on with pliers to save buying the crimps?

Failing that, will bodge …


#4

Please send couple of photos of the broken bits so that we can help you


#5

Hi mate,

The good news, I managed to shove two pins out the sowing kit into those connectors, snip them to length, and put the sensor back on. Booted the thing up, the app now shows the temperature again :slight_smile:

The bad news, the same thing happens with the screen, nothing ever shows up apart from all the various boot stages. The actual Hestia UI never shows.

I tried the trick you explained about the HAB panel. Before refixing the sensor, the main box had a great big Python exception in it. Now the UI that should be on the touch screen looks fine in there, but it’s not appearing. Touching the screen does nothing.

Thoughts?


#6

The python exception is because it was missing some important hardware, the sensor that is :slight_smile:

Can you access HestiaPi from your phone/laptop?
Is it an empty black/blank screen? A photo would always help :wink:
If yes, can you try and slide your finger to the right?


#7

Hi,

Yeah, the app works, lap top can connect HTTP and SSH. The UI loads fine on the HAB panel through the browser.

Just blank screen on the unit after it’s finished booting.

I tried various swipes, and nothing happened :frowning:


#8
  1. Try killing Chromium browser via SSH by:

sudo pgrep chromium | xargs kill -9

Check you can select anything on the desktop or open the Start menu or something. Just checking the touch function of the LCD is ok. If not, shut HestiaPi down (sudo shutdown -h now) and gently push the LCD’s upper left corner further in. You said you broke one of the hooks keeping the LCD and Pi snug so I am suspecting this. If touch worked fine, continue below.

  1. Avoid the warning that it closed improperly by running this
sudo sed -i 's/"exited_cleanly":false/"exited_cleanly":true/' /home/pi/.config/chromium/Default/Preferences
sudo sed -i 's/"exit_type":"Crashed"/"exit_type":"None"/' /home/pi/.config/chromium/Default/Preferences
  1. And then launch Chromium again (it may look a bit different - ignore for now)

DISPLAY=:0.0 sudo -u pi /usr/bin/chromium-browser http://localhost:8080/habpanel/index.html#/view/HestiaPi?kiosk=on

If 3. worked run 1. and 2. again and launch like this

DISPLAY=:0.0 sudo -u pi /usr/bin/chromium-browser --disable-restore-session-state --disable-web-security --user-data-dir --noerordialogs --disable-session-crashed-bubble --disable-infobars --kiosk /home/pi/scripts/openhabloader.html &


#9

Had a play with some of those commands, not really any the wiser.

I went for a reinstall. Downloaded the image, dd copied it over, booted, attached to the WIFI, ran the shell script to turn it off American mode. All the while the screen was displaying things.

It loaded up and I got a blank screen again. I’m starting to think I’ve knackered the touch screen. Can I buy a new one from somewhere?


#10

when you face the problem with the LCD staying blank, run this

sudo pgrep chromium | xargs kill -9

If you see the desktop etc on the LCD it is clearly not a hardware issue.
Please let me know the outcome


#11

That doesn’t show the desktop, no. However doing a reboot from the SSH prompt got me the Hestiapi logo on the screen straight away.

Really weird.


#12

Hmmm… it looks like you killed the “touch” functionality of the LCD and probably by nicking/cutting that brown/orange ribbon cable on one of its sides. Can you check?
Also while you see the countdown on the screen’s loader with the HestiaPi logo (after a reboot), can you select any text by dragging your finger over it?
Or if you are quick enough before you even get the loader screen, try and see if you can click on the start menu or something.
I believe in both cases you will feel as if HestiaPi is not responding but in fact you are not producing any input.
Regarding replacement… there is a risk here because there are so many clones/copies on the Internet/eBay and you can never say for sure if it will work. My supplier only does wholesale so I cannot help you here.
Search on amazon or eBay for
“3.5 inch LCD Touch Screen 320 x 480 raspberry”
but make sure it uses the same chip and the PCB looks identical to yours.


#13

Does this look like the right thing?


#14

I suppose the other thing is can you sell me one? Then at least I’ll get the right thing …


#15

Looks right.
Does yours say XPT2046?
Otherwise we can send you one for 25 to UK.


#16

Hi mate, yes it does have that model number. It says 480x320 though, but I suppose it depends which way you look at things :slight_smile:

EDIT: Went for it and ordered one off there, does look just the same.


#17

Got my new screen, great big crack down the middle trying to get it to line up and go into the pins … sigh …


#18

:frowning:
Maybe you can get the adhessive touch film off the cracked one to fix your original one. Never done this before…


#19

Also, I just tried booting up with the lid off as can’t get it on at all. UI is upside down, so I must have ordered some fruity backwards version of the screen. Uuuuurgh.


#20

Flipping the image in LCD is easy.
Check the LCD section here


and try running the command
sudo ./LCD35-show
with the desired rotation like so
sudo ./LCD35-show 180

I have never done this either but should work.