[SOLVED] Wifi not enabling


#1

Evening all, I think I’m on a steep learning curve here and I’m happy for someone to tell me I’m making a dumb mistake. the WiFi on my Pi will not start when running the Hestia OS, I’ve tried standard raspbian and it starts no problem, I’ve tried this on both a Pi3 and zero w and had the same result.
I’ve edited the wpa_supplicant.conf with the WiFi settings but it would seem that the actual WiFi chip set isn’t starting.
While the loading screen is showing its also shows both the WiFi IP address and MAC address as not available
Any ideas?
:confounded:


#2

Which RPi3 version do you have?
How did you edit the wpa_supplicant.conf?
Could you please try your RPi3 with Ethernet cable, SSH into your Pi and send us back the output of each of this commands?
ifconfig
wlist wlan0 scan
ls -la /etc/wpa_supplicant/wpa_supplicant.conf
and
cat /etc/wpa_supplicant/wpa_supplicant.conf
(maybe mask you WiFi’s password with a few * characters)

Are the contents of wpa_supplicant.conf the same in both the Hestia OS and raspbian?


#3

It’s a RPi3 b v1.2,
I edited the the wpa_supplicant.conf via SSH and have also tried copying the file across from the Raspbian install, I did the original without the quotes but noticed that the one from Raspbian has them in after setup.

List of returns from your list below.

ifconfig
eth0 Link encap:Ethernet HWaddr b8:27:eb:d4:26:57
inet addr:192.168.1.71 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: 2a00:23c4:eb85:7d00:b068:6707:6e44:9843/64 Scope:Global
inet6 addr: fe80::93ec:4b54:90d7:309e/64 Scope:Link
inet6 addr: fdaa:bbcc:ddee:0:e30:11bf:57f0:516b/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:342 errors:0 dropped:0 overruns:0 frame:0
TX packets:366 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:190956 (186.4 KiB) TX bytes:50575 (49.3 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:212 errors:0 dropped:0 overruns:0 frame:0
TX packets:212 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:17376 (16.9 KiB) TX bytes:17376 (16.9 KiB)

wlan0 Link encap:Ethernet HWaddr b8:27:eb:81:73:02
inet6 addr: fe80::8c05:5a70:901e:cd5d/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

iwlist wlan0 scan
wlan0 No scan results

ls -la /etc/wpa_supplicant/wpa_supplicant.conf
-rw-r–r-- 1 root root 136 Jun 21 22:51 /etc/wpa_supplicant/wpa_supplicant.conf

cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
ssid=“BTHub6-S3HM”
psk="**************"
}


#4

Spotted!
The quotes of the SSID are probably copied from a web page.
ssid=“BTHub6-S3HM”
Notice they are different from the quotes of the password. Use the ones you have for the password and let us know


#5

Same problem after the change,
I think that may have been something with the copy/paste as it’s the same file used in the Raspbian install and it connects no problem, even if that was the case I would expect the scan to show available networks as it does with Raspbian

iwlist wlan0 scan
wlan0 No scan results


#6

True…
Try the 3 suggestions here

  1. Scan with sudo (just for our information - not a solution)
  2. Use the wpa_supplicant tool
  3. Remove the country entry from the wpa_supplicant file.

A clean copy of the file is always here
/home/pi/scripts/wpa_supplicant.conf
which also resides in our github repo (which does not include country either so I think it may be it).


#7

After much more playing around copying and editing still no joy,
If I sudo the scan it picks everything up.
If I run “sudo wpa_supplicant -iwlan0 -c /etc/wpa_supplicant.conf” it connects to the wifi.
I have copied the Wpa conf file from the repo
I have tried the edits suggested in the link you posted
As a last hope I have created a new sd card with version 8 on

Nothing :confounded::confounded::confounded:


#8

Not sure if it matters, but is your WiFi hidden? I would search generic RasPi forums for an answer. It is something strange and haven’t heard of others here with the same image and hardware face it…


#9

Finally got it working!!!
There is something odd about my windows 10 PC, a little while ago I installed some software on my work laptop (also windows 10) to allow me to view Linux partitions on an SD card so as a stab in the dark I tried the SD cards in that and they didn’t seem to read correctly so (still on the laptop) I downloaded the image and wrote it to the card again, edited the wpa.conf file and tried again, now it works???

So now it’s just the long slog of learning OpenHAB and getting the panel design I want :smiley:

Thanks for the help, I’ll be outside thrashing my PC with a bat!!!


#10

Don’t smash it just yet… You can simply install Linux Mint or Ubuntu and have all the fun you want :wink:
Anyway… glad you got it working and most importantly you found the reason.


#11