Traces exploded!

I finally had chance to look at installing my HestiaPi, EU model.

I am UK based. I wanted to replace my thermostat, although we have a separate timer control programmer inside the boiler cupboard which I’ll keep. I am happy to only control heating anyway.

I initially wired everything up as directed, and when turned on saw the screen was flickering and rebooting, seemingly in a loop, so thought there was a power supply issue. I disconnected the blue Heating wire and tried again. I left it longer this time, and after a few reboots, it finally booted.

I then thought, perhaps it was working, and simply didn’t leave it long enough while all 3 cables were attached.

So reconnected to blue wire, and boom! The traces on L and H are gone! As per photos.

The only thing I can think I did differently was turn the power back on the breaker, and then turn the heating switch on the programmer very quickly, so this may have caused a serge?

I might tried to solder some wires back, unless there is something I am doing wrong?

The screen flickering and and boot cycles do not happen when testing with just the USB power. I retested after the indecent on USB again and it appears to still boot (without any cycles or flickering)

Photos of the wiring (and blown traces) are here:
https://drive.google.com/drive/folders/1bZB5h-pVdE1sumZA0E7olr_kvD59JQ4U?usp=sharing

Maybe on the diagram on the thermostat I am replacing, I have the wires messed up?
Old thermostat wiring diagram.jpg

I differed: Red = L, Yellow = N, and Blue = H.

Fortunately nothing else was damaged other than the 3A fuse for the central heating system, which was a bit difficult to replace at this time of year (several shops I went to were out of 3A!).

Not sure I can help regarding your house wiring. Have you tried connecting the Heating wire after all is booted and powered, that is working on live mains. If this does not trigger a surge (or short) then your old system could handle that while HestiaPi doesn’t handle shorts of surge over the rated amp/voltage.
Please report here your findings…

Hi yes, got this working. If you look at the wiring in the photos, I connected H and N the wrong way around.

I managed to fix the traces and it all worked fine for a few weeks. However just last week the thermostat suddenly always reporting 0. Tried rebooting and checking the thermostat and other connections. Also the screen input is very laggy now. I guess I should try a software update?

if you have a spare SD card try a clean install without losing your existing setup. I’m not sure if the damage could kill the temp sensor or any of the lines/connectors. Make sure the pinout of the sensor’s cable is correct too.