V10.3 image release


#1

Download Link
Google Drive 1.7GB
Filename: hestia-pi-touch-v10.3.zip
MD5 Hash: bd1ed37a0e91c5607bde4934c1986be3
Version 10.3 Details:

  • All v9.2 features plus:
  • Stretch update: We have upgraded to the latest stable distro release
  • New optimised LCD driver for faster response to touch events
  • Celsius, Fahrenheit, EU and HVAC support in the same image. HVAC mode and Fahrenheit are the default. See here for instructions to change mode. Use HVACDisable.sh or HVACEnable.sh.
  • Easily connect HestiaPi to your WiFi from your phone (no SSH needed). Full instructions here.

Detailed installation steps for Raspbian Stretch for people who want to avoid the image file and install it manually.

To monitor the OpenHAB logs without stopping the service run

openhab-cli showlogs

To start OpenHAB manually after stopping the service run

openhab-cli start

V10.1 image release
V10.1 image release
#2

Hoorahhh! Well-done @HestiaPi


#3

Will soon post all commands needed for a manual installation too. > DONE !
Looking forward to some feedback…


#4

I have the Image loaded and can confirm that uptime shows a low load average however I’m missing the log files for openhab how can I enable logging ?

thanks again @HestiaPi your hard work is appreciated


#5

The 10.x version hasn’t been that lucky…
I have faced the issue you mentioned trying to run manually OH like this

sudo service openhab2 stop;
sudo /usr/share/openhab2/start.sh;

It seems I hit a bug with the package installer as “sometimes” it fails to install properly without reporting an error. I don’t like this “sometimes” but a lot of people report so in the OH forums. The funny thing is that it runs absolutely fine but logging is messed up and running it manually also bugs out.
So a 10.3 is inevitable within the next days I am afraid.
If you want to troubleshoot it yourself I would advice to disable the SD card optimisation out to have one less variable to worry about:

sudo nano /etc/fstab

and comment out the last 3 lines like this:

#tmpfs           /var/tmp        tmpfs   nodev,nosuid,size=50M  0  0
#tmpfs           /tmp            tmpfs   defaults,noatime,nosuid,size=100m 0 0
#tmpfs           /var/log        tmpfs   nodev,nosuid,size=50M 0 0

I tried purging and reinstalling…

sudo apt-get remove --purge -y openhab*
sudo apt-get install  openhab2 openhab2-addons 

as some suggested and even manually make missing folder under user openhab.

Grrr…


#6

Sorry I keep finding problems for you.

I’ll see what I can find out .

Strange that purgong openhab and re installing didn’t fix it
:thinking:


#7

10.3 version uploaded! Post updated with latest version.
OpenHAB has some things changed in Stretch so make sure you read the bottom of the updated top post here:

This was the reason we thought so many things were wrong in 10.2 but if fact they were not :slight_smile:


#8

A previously fixed bug on OpenHAB reappeared with our latest update of OpenHAB migrating to Stretch, so if you use this image, you will notice that tapping on LCD buttons that have an icon, most of the times produces a drag event on the icon rather than pressing the button.

A simple solution for this is to run these over SSH:

sudo /home/pi/scripts/update.sh && /home/pi/scripts/update.sh;

For (US) people using the HVAC mode on the LCD run these:

sudo cp /home/pi/scripts/habpanel.hvac.config /var/lib/openhab2/config/org/openhab/habpanel.config;
sudo /home/pi/scripts/HVACEnable.sh;

For (EU) people using the EU mode on the LCD run this:

sudo cp /home/pi/scripts/habpanel.nohvac.config /var/lib/openhab2/config/org/openhab/habpanel.config;

and finally reboot

sudo reboot;


#9

Hello!
I come back to this project after a few months away. Backed-up modified stuff for DHT22 sensor and flashed the new version, but this time the Adafruit library is completely missing. I planned to investigate it in the next days, did someone already checked and solved this?

EDIT:
Sorry, forgot an important fact. I had trouble flashing the image on a 4Gb uSD… is my memory broken or the image is a bit too large?


#10

Hello! Long time no see :slight_smile:
DHT support is removed with 10.x images when we moved to Raspbian Stretch.
You can visit the Jessie instructions section for installing what DHT needs and then you will need to modify your things file. The rest should still be there. Let us know in a new post so that others learn too.
Ciao!