White LCD from Crowd Supply deluxe version


#1

Hi,

I received my assembled “deluxe” version, unfortunately it seems like it got badly rattled in shipping. The box was fine, but the guts inside the 3D print were scrambled – LCD mount tabs were all broken off, as were the friction fit pins holding the PCB to the wall plate.

When I apply power from a large 16VAC transformer (alarm panel) everything appears to power up, the LCD comes on full bright and the Pi activity light begins flickering. Unfortunately even after 10-15 mins to LCD is still full bright with no text or other display. I tried reseating the display, SD card, resetting by power removal and reapplication, but the result is the same.

The Pi is soldered to the PCB, and I have no way to plug into either USB or mini-HDMI as they are blocked by relays and AC-DC converter.

Seems to be no way to access the device as it’s not on my network and I have no display or physical interface.

Any ideas what I can try to salvage this?

I do have other Pi Zero W’s, so I could boot the SD in one of those to get it on WiFi, or add my WiFi info to the /boot area…


#2

The power supply for the HVAC model is for 24V AC. We haven’t tested it for 16V AC. If the LEDs on the Pi blink for a few seconds and not for the first 1-2 minutes then we believe it is a power issue.
Use 24V AC.


#3

The Pi lights are blinking for a long period, not just seconds.

The supply brick for my HVAC model has a rating listed on it that says 8VAC to 24VAC for input and a fixed output value of 5VDC, so I assume it should be OK on 16VAC – however, to rule it out as a problem I am using my bench supply for the 5VDC… still no joy on the LCD.

I enabled ssh and added my local WiFi via wpa_supplicant.conf to the boot area – now that I’m SSH’d into the device is there any logging that I can check to determine why the display isn’t working? I’m trying to rule out bad software vs. hardware at this point and hoping for software (but doubt it).


#4

If you have a multimeter with continuity check I would like you check continuity between the pin header of the LCD (turn HestiaPi off and remove the LCD) and the pin header of the Pi facing the board from the components side. Pin 1 (bottom left) with pin 1 (bottom left), pin 2 with pin 2 and so on for all LCD’s pins. It may be a bad solder point on the Pi’s pins at the bottom side. Try and refresh the solder and retest.


#5

I checked at the pins for each header, continuity was good between each respective pin.

Do you have a link to buy a new display? I know it seems there was some concerns with drivers or whatever else so I want to be sure I get the correct one, but if it’s cheap I’m willing to buy another to test if it could be the display itself.

I will also try this display on another PiZ with headers.


#6

The supplier used to have an eBay shop. I’ll check if that’s still the case and let you know.
As all LCDs were tested before shipping, I doubt it would be a faulty LCD unless there is something cracked. Can you check the orange ribbon cable flex around one edge? Make sure there are no dents or nicks on it.
You can also try removing the LCD from the case and attaching it as far as it goes on the Pi’s header (the SSRs will block one side so leave pluged in at an angle).


#7

My device was scrambled hard in shipping – the LCD mounts were broken, the Pi PCB was also detached from the wall plate.

This is why I’m suspecting I may have a bad LCD (only because the Pi functions OK, so it doesn’t seem damaged)

I started contact via Crowdsource about the concern, but then headed over here to see if maybe there was something else that I might be able to check.


#8

Aouch! That looks awful :frowning: Have you got any reply from CrowdSupply? We shipped bulk to them and confirmed they only got 3 cracked. They deal with the packaging and delivery so they should cover you.
Can you try this:

and also confirm the ribbon below looks in tact.


#9

I don’t see any obvious damage to the ribbon cable.

I tried the LCD on another RPi Zero-W that I know is good, I also tried clean HestiaPi Touch 10.4 SD card image (also tried the ONE 1.1 image) and the LCD is always simple “white” with no display.

The Pi Zero-W that arrived w/ the kit otherwise seems to work and I’m able to SSH into it.

I haven’t heard from CrowdSupply, but I think it’s possible I clicked on a link to contact that Creator of the project instead of CrowdSupply themselves, so I repeated my contact attempt but this time being careful to choose contact CrowdSource.


#10

Have you tried this? Connect the LCD directly on the Pi, not the 2nd header above as it normally goes.


#11

I’ve tried connecting the LCD directly the header in the Hestia (push it further). I cannot connect directly to the Pi in the Hestia because it has no header pins.

However I have plugged it directly into a second Pi I have, with the Hestia SD card, and it behaves the same way – just white, no display.

I haven’t heard back from Crowd Supply after they requested pictures of the damage, so I emailed them again today.


#12

What do you mean? The Pi should have male headers and the LCD have female. In any case I believe you should ask for a refund as it got broken and it may have damaged something in the LCD not visible as I cannot troubleshoot any further remotely.