Automated build process (buster)

I have not had any display problems. Here are the 2 that I am using.

Downloading and testing now.

Basic testing and every looks okay. You can also remove accounts-daemon.service.

Suggestion: Add decimal place to Fahrenheit Temp and Humidity. Allow .5 step for temp differential step.

Changes to add decimal to temp and humidity for both C and F.

diff scripts/oneui/js/app.8debb52b.js.orig scripts/oneui/js/app.8debb52b.js
<       if ( === 'C') {
<       } else {
<         store.state.currentTemperature = parseInt(message);
<       }
<       store.state.currentHumidity = parseInt(message);
>       store.state.currentHumidity = message;
<       store.state.modes.humidity.setValue = parseInt(message);
>       store.state.modes.humidity.setValue = message;

diff scripts/ scripts/
<   print "Temperature : ", int((temperature*1.8)+32), "F"
>   print "Temperature : ", round(((temperature*1.8)+32),1), "F"

Remeber to copy the to

If I had a spare Raspberry Pi 3 laying around I would be more than happy to help test, but since those are all out of stock as well I don’t want to do too much testing with my current thermostat setup! If I can scare one up I’ll jump in and help as much as I can!

If you have an extra micro SD card, you can flash that with this testing image and then just swap SD cards. Give the new one a try and then swap back yo your main system. This is the safest way to test it out.

Updated image disables the accounts-daemon.service. No other changes.

If you have a GitHub account and can submit this chsnge as a merge request from the HestiaPi/hestia-touch-openhab repo, I can just rebuild the image and it’ll have this feature.

If not, I can submit your patch at some point. I’m just not sure when I’ll get to it.

I can confirm that the countdown starts showing the, say, 10 min, and stays there. No countdown, no triggered action after the time has elapsed (even though the minutes never go down).

Committed just now.

This call is to determine the public IP of HestiaPi to help you setup external access without using OpenHAB’s (free) cloud service. It is then shown on the LCD on the information screen (i icon top right). Ideally it should be easily enabled/disabled from UI with disabled as the default. In terms of privacy/security I doubt it adds any risk.

Downloading… I expect the LCD to behave the same…

I need to check that a little bit more as I don’t think humidity is often expressed with decimals. It sure adds accuracy but also may clutter the UI. Looking around many commercial UIs, I only see decimals in Celsius which are much larger units (20C is 68F while 21C is ~70F) and need more precision. Humidity on the other hand has always been shown as integers. I’d rather leave it as it is unless others need it too.

Yes I have a git hub account. I will look at the source java files and submit a request.

I have done energy management with Andover Controls since the 80’s. We have always used at least 2 decimal place to show rapid changes in temperature or humidity. I am also using a main openHAB server to graph the HesitaPI devices as a remote server which is working very well. It also a lows remove control of each unit. In my case I will have 4 units, 1 for the main temp in the house, 1 to run the backup heat system, 1 for the shop/barn and one for our storage building. I have a public weather station that I run and publish to the NOAA and can use that data to affect the info that can be sent to the HestiaPI devices.

I am able to reproduce the issue with the boost being stuck at 10 minutes. It doesn’t happen when the system is set to HVAC, only when it is set to “Generic”. To troubleshoot, I watched openhab.log as I clicked the boost button. This displayed an error message:

2023-03-21 10:23:23.727 [ERROR] [e.automation.internal.RuleEngineImpl] - Failed to execute rule '5635a61b-859b-48d5-82f4-a53f6e1c34d1': Fail to execute action: 2

I went into the PaperUI → Rules and clicked the run icon next to “Boost Looping Timer” and I saw a more detailed error message:

Details of the java.lang.ClassNotFoundException error

2023-03-21 10:24:01.331 [WARN ] [e.automation.internal.RuleEngineImpl] - Fail to execute action: 2
java.lang.RuntimeException: java.lang.ClassNotFoundException: org.eclipse.smarthome.model.script.actions.ScriptExecution cannot be found by com.eclipsesource.jaxrs.publisher_5.3.1.201602281253
at jdk.nashorn.internal.runtime.ScriptRuntime.apply( ~[nashorn.jar:?]
at jdk.nashorn.internal.runtime.Context.evaluateSource( ~[nashorn.jar:?]
at jdk.nashorn.internal.runtime.Context.load( ~[nashorn.jar:?]
at jdk.nashorn.internal.objects.Global.load( ~[nashorn.jar:?]
at jdk.nashorn.internal.scripts.Script$125$^eval_.:program(:2) ~[?:?]
at jdk.nashorn.internal.runtime.ScriptFunctionData.invoke( ~[nashorn.jar:?]
at jdk.nashorn.internal.runtime.ScriptFunction.invoke( ~[nashorn.jar:?]
at jdk.nashorn.internal.runtime.ScriptRuntime.apply( ~[nashorn.jar:?]
at jdk.nashorn.api.scripting.NashornScriptEngine.evalImpl( ~[nashorn.jar:?]
at jdk.nashorn.api.scripting.NashornScriptEngine.evalImpl( ~[nashorn.jar:?]
at jdk.nashorn.api.scripting.NashornScriptEngine.evalImpl( ~[nashorn.jar:?]
at jdk.nashorn.api.scripting.NashornScriptEngine.eval( ~[nashorn.jar:?]
at javax.script.AbstractScriptEngine.eval( ~[?:1.8.0_222]
at org.openhab.core.automation.module.script.internal.handler.ScriptActionHandler.lambda$0( ~[?:?]
at java.util.Optional.ifPresent( ~[?:1.8.0_222]
at org.openhab.core.automation.module.script.internal.handler.ScriptActionHandler.execute( ~[?:?]
at org.openhab.core.automation.internal.RuleEngineImpl.executeActions( [bundleFile:?]
at org.openhab.core.automation.internal.RuleEngineImpl.runNow( [bundleFile:?]
at org.openhab.core.automation.internal.RuleEngineImpl.runNow( [bundleFile:?]
at [bundleFile:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_222]
at sun.reflect.NativeMethodAccessorImpl.invoke( ~[?:1.8.0_222]
at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:1.8.0_222]
at java.lang.reflect.Method.invoke( ~[?:1.8.0_222]
at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke( [bundleFile:?]
at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher$ [bundleFile:?]
at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke( [bundleFile:?]
at org.glassfish.jersey.server.model.internal.JavaResourceMethodDispatcherProvider$ResponseOutInvoker.doDispatch( [bundleFile:?]
at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.dispatch( [bundleFile:?]
at org.glassfish.jersey.server.model.ResourceMethodInvoker.invoke( [bundleFile:?]
at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply( [bundleFile:?]
at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply( [bundleFile:?]
at org.glassfish.jersey.server.ServerRuntime$ [bundleFile:?]
at org.glassfish.jersey.internal.Errors$ [bundleFile:?]
at org.glassfish.jersey.internal.Errors$ [bundleFile:?]
at org.glassfish.jersey.internal.Errors.process( [bundleFile:?]
at org.glassfish.jersey.internal.Errors.process( [bundleFile:?]
at org.glassfish.jersey.internal.Errors.process( [bundleFile:?]
at org.glassfish.jersey.process.internal.RequestScope.runInScope( [bundleFile:?]
at org.glassfish.jersey.server.ServerRuntime.process( [bundleFile:?]
at org.glassfish.jersey.server.ApplicationHandler.handle( [bundleFile:?]
at org.glassfish.jersey.servlet.WebComponent.serviceImpl( [bundleFile:?]
at org.glassfish.jersey.servlet.WebComponent.service( [bundleFile:?]
at org.glassfish.jersey.servlet.ServletContainer.service( [bundleFile:?]
at org.glassfish.jersey.servlet.ServletContainer.service( [bundleFile:?]
at org.glassfish.jersey.servlet.ServletContainer.service( [bundleFile:?]
at com.eclipsesource.jaxrs.publisher.internal.ServletContainerBridge.service( [bundleFile:?]
at org.eclipse.jetty.servlet.ServletHolder.handle( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.servlet.ServletHandler.doHandle( [bundleFile:9.4.20.v20190813]
at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle( [bundleFile:?]
at org.eclipse.jetty.server.handler.ScopedHandler.handle( [bundleFile:9.4.20.v20190813]
at [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.handler.HandlerWrapper.handle( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.session.SessionHandler.doHandle( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.handler.ContextHandler.doHandle( [bundleFile:9.4.20.v20190813]
at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle( [bundleFile:?]
at org.eclipse.jetty.server.handler.ScopedHandler.nextScope( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.servlet.ServletHandler.doScope( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.session.SessionHandler.doScope( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.handler.ScopedHandler.nextScope( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.handler.ContextHandler.doScope( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.handler.ScopedHandler.handle( [bundleFile:9.4.20.v20190813]
at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle( [bundleFile:?]
at org.eclipse.jetty.server.handler.HandlerWrapper.handle( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.Server.handle( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.HttpChannel.handle( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.server.HttpConnection.onFillable( [bundleFile:9.4.20.v20190813]
at$ReadCallback.succeeded( [bundleFile:9.4.20.v20190813]
at [bundleFile:9.4.20.v20190813]
at$ [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce( [bundleFile:9.4.20.v20190813]
at [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob( [bundleFile:9.4.20.v20190813]
at org.eclipse.jetty.util.thread.QueuedThreadPool$ [bundleFile:9.4.20.v20190813]
at [?:1.8.0_222]
Caused by: java.lang.ClassNotFoundException: org.eclipse.smarthome.model.script.actions.ScriptExecution cannot be found by com.eclipsesource.jaxrs.publisher_5.3.1.201602281253
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal( ~[org.eclipse.osgi-3.12.100.jar:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findClass( ~[org.eclipse.osgi-3.12.100.jar:?]
at org.eclipse.osgi.internal.loader.BundleLoader.findClass( ~[org.eclipse.osgi-3.12.100.jar:?]
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass( ~[org.eclipse.osgi-3.12.100.jar:?]
at java.lang.ClassLoader.loadClass( ~[?:1.8.0_222]
at org.eclipse.osgi.internal.framework.EquinoxBundle.loadClass( ~[org.eclipse.osgi-3.12.100.jar:?]
at org.ops4j.pax.swissbox.core.BundleClassLoader.findClass( ~[bundleFile:?]
at java.lang.ClassLoader.loadClass( ~[?:1.8.0_222]
at org.ops4j.pax.swissbox.core.BundleClassLoader.loadClass( ~[bundleFile:?]
at java.lang.ClassLoader.loadClass( ~[?:1.8.0_222]
at java.lang.Class.forName0(Native Method) ~[?:1.8.0_222]
at java.lang.Class.forName( ~[?:1.8.0_222]
at jdk.nashorn.internal.runtime.Context.findClass( ~[nashorn.jar:?]
at jdk.nashorn.internal.objects.NativeJava.simpleType( ~[nashorn.jar:?]
at jdk.nashorn.internal.objects.NativeJava.type( ~[nashorn.jar:?]
at jdk.nashorn.internal.objects.NativeJava.type( ~[nashorn.jar:?]
at jdk.nashorn.internal.objects.NativeJava.type( ~[nashorn.jar:?]
at jdk.nashorn.internal.scripts.Script$Recompilation$127$34A$utils.L:3(/etc/openhab2/automation/lib/hestia/utils.js:31) ~[?:?]
at jdk.nashorn.internal.scripts.Script$126$utils.:program(/etc/openhab2/automation/lib/hestia/utils.js:3) ~[?:?]
at jdk.nashorn.internal.runtime.ScriptFunctionData.invoke( ~[nashorn.jar:?]
at jdk.nashorn.internal.runtime.ScriptFunction.invoke( ~[nashorn.jar:?]
at jdk.nashorn.internal.runtime.ScriptRuntime.apply( ~[nashorn.jar:?]
… 79 more

This looks like it might be a bigger issue than just the boost not working as expected. It’s also worth noting that this is the same problem as the Can’t stop boosting thread which was experienced on the official 1.2-dev image. We never really got to a root cause or resolved that one, but rather just worked around it. I just restored the stock 1.2-dev image, which does not have this issue. I’ll try to get to the bottom of this issue this time around.

Before going any further, I switched back into HVAC mode to run these same tests and see if the error message and stacktrace also appears when the timer is working properly. If so, then they can likely be ignored. It turned out, the error & stracktrace did not appear.

Logs when boost is working properly

2023-03-21 10:47:00.544 [INFO ] [.eclipse.smarthome.model.script.mode] - Heating mode changed from OFF to Boost
2023-03-21 10:47:02.439 [INFO ] [eclipse.smarthome.model.script.boost] - Starting Heating boost
2023-03-21 10:47:03.699 [INFO ] [eclipse.smarthome.model.script.boost] - 10 minutes remaining on boost for Heating
2023-03-21 10:47:10.849 [INFO ] [marthome.model.script.heatingcooling] - TURN ON Heating: heating delta is 14 cooling delta is -18 hysteresis is 1
2023-03-21 10:47:14.353 [INFO ] [lipse.smarthome.model.script.heating] - Turning ON the heater: curr temp = 56 setpoint = 70 mode = Boost
2023-03-21 10:47:25.839 [INFO ] [.eclipse.smarthome.model.script.mode] - Fan mode changed from OFF to AUTO
2023-03-21 10:47:28.890 [INFO ] [] - FanMode is AUTO
2023-03-21 10:47:31.938 [INFO ] [] - Turning ON the fan: fan mode = AUTO
2023-03-21 10:47:33.563 [INFO ] [.eclipse.smarthome.model.script.pins] - Commanding Pin12 to ON for HeatingPin
2023-03-21 10:47:33.899 [INFO ] [.eclipse.smarthome.model.script.pins] - FanPin commanded to ON
2023-03-21 10:47:34.270 [INFO ] [.eclipse.smarthome.model.script.pins] - Commanding Pin18 to ON for FanPin
2023-03-21 10:48:04.858 [INFO ] [eclipse.smarthome.model.script.boost] - 9 minutes remaining on boost for Heating

I switched back into Generic mode and did a few hours worth of debugging. I didn’t solve this one, but here’s a summary of what I learned:

  1. “Hot Water Control” and “TempUnit changed” rules had this same stacktrace when run, but “Process Sensor Changes” did not. I didn’t see any pattern in which rules raised an exception and which ones did not
  2. I found that if I load util.js in the Boost Looping Timer rule, I get the exception and if I don’t load utils.js, I don’t. Digging further, the two lines that will cause this exception are Java.type("org.eclipse.smarthome.model.script.actions.ScriptExecution") and Java.type(""). However, Java.type("org.slf4j.LoggerFactory") did not cause any exception.
  3. I found two ScriptExecution classes online. The one our code is trying to load is in the (now archived) smarthome project. The other is in OpenHAB. They look similar, but they are not the same. Calling Java.type("") also raised a ClassDefNotFound exception.
  4. I noticed that jaxrs seems to be the thing trying to load ExecUtil (from the error: cannot be found by com.eclipsesource.jaxrs.publisher_5.3.1.201602281253). I found the Maven page about this version of this library. Going to the project HomePage shows us this project is also archived and no longer maintained.
  5. Running dpkg -L openhab2 shows some config related to “smarthome”, but no jar file. The jaxrs v5.3.1 jar file does appear in this list. /usr/share/openhab2/runtime/system/com/eclipsesource/jaxrs/publisher/5.3.1/publisher-5.3.1.jar. I don’t see any jar files that look like they would have the Eclipse of version of ExecUtil, but I did find /usr/share/openhab2/runtime/system/org/openhab/core/bundles/ which I would expect to contain the OpenHAB version of ExecUtil.

The glaring questions remain: why can the Boost Looping Timer rule find this Class in the US mode (HVAC), but not in the EU mode (Generic)? and why don’t all rules have this issue in EU mode?

I’ll keep plugging away and see if I can make any progress at answering these.

As for the LCD screen, I’m perplexed. Our screens look identical as far as I can tell. It doesn’t make any sense why they are behaving differently. Since we currently have two people reporting that it’s working as expected, I think what is in the image now should be the default, but we should have a single command that anyone having issues can run to swap over to the alternative configuration.

Maybe call it something like ./, put it in the scripts directory and make the content something like the following?

echo 'Section "InputClass"
        Identifier      "calibration"
        MatchProduct    "ADS7846 Touchscreen"
        Option  "Calibration"   "254 3910 3716 1476"
        Option  "SwapAxes"      "1"
        Option "InvertX" "1"
        Option "InvertY" "1"
EndSection' | sudo tee /etc/X11/xorg.conf.d/99-calibration.conf > /dev/null
sudo shutdown -r now