May I test HestiaPI on a Pi Zero device with no other hardware?

I am very happy of having found HestiaPi to fill in my needs of a smart thermostat not bounded to a cloud service or tied to an automation trademark.

But for now HestiaPi is not in production, I will have to wait for the new boards from china.

Is it possible to install the image in a Pi Zero W and have openhab working?
Of course the heating system would not work and there is no touch device, but I could see how the openhab interface it, how it can be configured…

Or it won’t work at all and even not boot?

Is it possible to install it in a virtualbox virtual machine?

Thank you for answers.

Yes, you can put the image on an SD card and boot it on a Pi Zero W without any additional hardware.

This means you will not have the screen, but the initial setup (telling it what wifi access point to connect to and providing the access point’s password) is done by connecting your mobile phone to the pi’s wifi, so installation should still go smoothly.

After the setup is complete, the pi will appear on your network. Again, since you won’t have a screen yet, you will have to determine it’s IP address some other way, but once you do, you can connect to the web interface and see how all of that works.

If you have headers that you can solder onto the pi, you could even set up some LEDs to show when certain circuits are on or off.

On a related note, I do have some extra HestiaPi PCBs that I’m not using. If that is the only thing you’re waiting on, and you are in the US, send me a direct message if you are interested.

1 Like

Thanks a lot for your answer, and for your offer.

But no, I am not in US, I am in Spain.

It is not only a matter of PCBs (but having the PCB is a good starting point) it is a matter of having the Relays and mounting the touch screen.

May be I could try with more time, but if there is the option of buying it already mounted is better for me.

I have the R Pi Zero W and the BME280 but not the Relay swiches or the Power Unit.

If it uses DHCP to get the IP address, I will be able to know the assigned IP in the router.

I have installed mqtt in the router too, as it is an always on device, and I have a qnap device too to make tests with openhub in docker.

I’m trying to ahold of a Raspberry Pi Zero 2 so I can build a next gen HestiaPi One, but I’m having similar problems with getting parts. If I can get a new one built and working, I won’t need my existing (fully assembled HestiaPi), but that’s likely not going to be any time soon. Still, it might be before production ramps up. I’ll post here in the General category when I’m looking to sell mine.

Edit to add: I just found out that shipping would be $150 to Spain! For comparison, it’d be $13 to ship it to Los Angeles or $24 to New York City.

I will try to use what I have now.

If it works I will see if I can add an power supply and the relays, won’t be as difficult to make the pc board (even with a test board and cables as there are not so much wiring).
Te touch screen seems to be just a standard one that connects directly to the pi zero pins.
The big problem would be to present it in a box that is beautifull enough to put it in the dining room, and put the PCB in place without movment.

It might be worth checking with your local library to see if they have a 3D printer. I was surprised to find that the library in my small town had one.

1 Like

Well yes, for sure I will find one in the University.
Thank you.
I will try these days to see if I can put it to work in a prototype.

If it works and there it is not available yet from this site, I will try to assemble one.

I have already downloades the 1.1 image and burned it in the SD.
I have power on my Pi Zero and now I can see the HetiaPi WIFI LAN, but it asks for a password in order to get connected to it.
Which is de default password?

OH, sorry, I could find it in the installation instructions.

Well I have installed HestiaPi in my RPi Zero device, initiated it and configured wifi.

I can access the web interface.
But after all night running, openhab continues showing the “Please stand by while UIs are being installed. This can take several minutes.” message.

I can connect to the RPi via ssh, but everything seems normal, no message of failure.

What is going on?

I suppose this is not the normal behavior it cannot take so long to initiate.

Please prefer the 1.2-dev version as it includes many optimisations and improvements in speed. Don’t be scared by the -dev on the name. It is safer than 1.1 :slight_smile:

1 Like

Will try, thanks.

I have tried the 1.2 devoloper version. It works now, I could install and run it and it did not get locked in openhab first run install process.

Thank you.

2 Likes