Open wifi issue


I’m having issue with the Raspberry turnkey when connecting to open wifi. The web form Wont let me pass until the password field is filled.(message indicating “please fill the field”)

I opened the to understand the way it works. I found comments in code that indicate that when password=Null the script should configure the wpa_supplicant with the propre informations. So i dont see why the webform block me from leaving the password field blank.

I tried to manually configure the wpa_supplicant.conf with not luck.



maybe it is a restriction that is hardcoded by the actual form by html and javascript

I confirm that the password form in index.html contains the argument “required”.
Once removed from the string the portal let me pass whitout password, but the web page give an internal error and nothing happens.

I’m not really a python Guy but i spent many hours trying to teach myself some basics but it’s too advanced for a green Guy like me…

I also tried to manually configure the wpa_suppliquant.conf with no luck.
It’s really hard to debug because once it’s rebooted all files are cleaned so i’m left clueless.

It’s sad because the thermostat work perfectly in my RV but as long as the wifi donc work it’s mostly useless for me.

Have you checked if turnkey has an update where they support open WiFi?

Yes i did open an issue but it remained unanswered. Sadly there is no forum where i can call help from the comunity. I wish i could make this work by hand

Wow, I totally missed this thread until now. I’ve been getting pretty friendly with the turnkey code as of late.

I’ll try to stand up an open test network and figure out the steps required to allow turnkey to work with open access points.

If I fail at that, hopefully I can ateast get you a wpa_supplicant.conf file that you can use.

1 Like

This should work for the open WiFi. Replace the network portion of wpa_supplicant.conf with this.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.