Zip folder empty after downloading on Windows

Back in March an individual was having issues downloading the zip folder containing hestiapi and on windows and then having the folder appear empty once it was downloaded, I am having the same issues as well. I have tried the newest version and also the previous version, same results with both. On several different computers and different internet. The folder downloads fine, it says it’s 2GB but when you click on it it is empty. I tried the previous posters solution which was downloading it on the raspberry pi and the iso and md5 files were there but then I ran into unzipping issues… And putting it on a flash drive after the raspberry pi downloaded it and moving it to a windows machine to unzip it reauled in nothing appearing in the zipped folder. Any suggestions on how to solve this? I’d really like to get one up and running!

Are we talking about this download link:
https://drive.google.com/file/d/1Svh0g9MM-7DWl7UTCQ2Goo3ak4R0w7uJ/view
(from HestiaPi Touch ONE v1.2-dev release)
Could you try use incognito/private mode from on your browser? (Ctrl+Shift+P for Firefox, Ctrl+Shift+N for Chrome)
Does the download take a reasonable amount of time for 2GB?

Correct, that is where I tried it from. It took about 7-10 minutes to download which I thought was a decent time but I have 100mbps download speed so if my math is correct it should’ve only taken around 30 seconds… but it took at least that 7-10 minutes on every computer. The file properties once it’s downloaded say it’s 2GB. I did try incognito mode on two of the computers I believe, I tried Chrome and Edge, then Firefox on an old laptop that I put Linux on, didn’t use incognito for that but it downloaded and appeared just fine on the laptop, it just wouldn’t unzip on there and when I moved it to a windows machine to unzip it the folder appeared empty again :man_shrugging:

I used an online calculator to check my math on the download speed and I was incorrect, it should have taken about 3 minutes under absolute ideal conditions, so if I lost some speed due to other devices then 5-10 minutes seems within reason.

I think I may have gotten in to unzip with 7zip instead of the windows tool, flashing to an sd card now to see if it works!

I did get it all working! Is there an explanation as to why the folder appears empty to windows but a third party program can unzip it just fine?

Great!

Not sure. We don’t use Windows to experience this. It is a large file compressed with standard zip method (not-Windows based though). That is the only thing that stands out, but I can tell you that it has been unzipped in Windows before. Not all our users are Linux-based.
Thanks for getting back to us. Enjoy!