Touchscreen not responding

Installed my Touch ONE this morning. Was able to get it working with OpenHAB and operating correctly, however it will not respond to any touch input on the lcd.

Can you try this solution:

Tried your suggestion, re-flowed solder on the PCB, problems persist

Can you confirm continuity test between each and every male pin of Pi and LCD header?
Lastly, with the Pi off, insert as far as it goes the LCD directly on the Pi’s header. The relays are stopping it for staying flat but under normal circumstances this is no problem. Check again for touch issues.

If the LCD is removed from the front cover and inserted by hand make sure they are centre aligned as the connector allows the pins to misalign and this may damage (further?) the LCD.

I’m thinking that my Pi may be fried, I think I had the LCD GPIO header offset to the right when I was putting the cover on. I tested all the pins with an Ohmmeter and it all checked out ok. I moved the LCD directly to the GPIO pins on the Pi itself with no improvement.I reflashed the hestia-pi-ONE-v1.1-HVAC.img using etcher on 2 different PCs. I am able to connect and set my wireless network. At this point, it won’t come off of the UI with zero’s. I let it sit all night and this am it was still all zero’s.

Waiting overnight is not realistic :slight_smile: If nothing is up after 30 minutes and command top reports below 0.5 CPU load, then something is dead.
Please run these commands over SSH:

sudo openhab-cli clean-cache
sudo openhab-cli reset-ownership
sudo restart

and check after 10 minutes that top reports high CPU load and after 20-30 it goes below 0.5. This is when you should see the LCD UI being populated.

These commands shouldn’t be needed under normal circumstances but we have seen some times file/partition integrity (wild guess, we don’t really know) is not maintained after flashing and openHab may fail to work properly. Please let us know if it worked for you so that others can try.

1 Like

This worked to restore openhab2. I am now able to use the app, and connect and make adjustments with my phone/PC. Since openhab2 was running I ran:

sudo systemctl stop openhab2
sudo openhab-cli clean-cache
sudo openhab-cli reset-ownership
sudo reboot

My touchscreen, however still does not register touches. Any diagnostic advice?


Since you have tested that too, I would believe the logic circuit for the touch of the LCD is fried :frowning:
I believe some people on the forum have found alternative (non-Asian) suppliers. Have a search around.

sounds like the problem, one of the sellers even has this graphic right on the sale page. Thanks for the help, I’ll get a replacement ordered shortly.

1 Like

Please pay attention to the “orientation” of the visible LCD area as it is not symmetrical/centered. Make sure the larger frame is on the right side while the female connector is at the top. Exactly as the one shown on the very well put image you shared above.

I am happy to report that, after replacing the touch panel, My HestiaPi is now fully functional. Thanks again for the help!

1 Like