HestiaPi ONE v1.4-dev release

Download Link - Mirror 1 - 1.5GB
Download Link - Mirror 2 - 1.5GB
Filename: hestia-pi-ONE-v1.4-dev-bullseye-6185.img.xz
MD5 Hash - 0a60eaf9219692428cb7216f63d4c92a

Place both files together and run
md5sum -c hestia-pi-ONE-v1.4-dev-bullseye-6185.img.xz.md5
to confirm.

Version ONE v1.4-dev details:

  • Based on previous 1.3-dev version (all features included)
  • Updated base distro to Debian 11 (bullseye)! This is supported by the Debian team until June 2026

There was a long discussion about the process of upgrading to Debian 11 and testing.


Thank you for this. The download link at the “Download – HestiaPi” page links to a gitlab that is inaccessable without an account.

@HestiaPi will be updating that link to match the one above. It worked at the time they added it, but GitLab only keeps the output from the latest job, so the files are gone and even people with accounts can’t use that link.

In the meantime, the link above works. I’ll make sure to provide a stable link for the next release to avoid this in the future.

GDrive link added as Mirror 1 for .xz and md5 file.

please i can’t connect thru ssh , bad password for pi and bad for openhab ,
where i can find this passwd ?

For SSH access:

username: pi
password: hestia

You can access OpenHAB without any authentication over HTTP on port 8080.

good morning,

I just realized my mistakes :slight_smile:.

I’m testing the application with a raspberry 3.

However I had not yet understood the procedure for implementing the application.

So far I had connected my RPI3 to my network via the ethernet port.

The rpi3 with the application connected to my ethernet network and I could use the Openhab Web interface via https://IP:8443/ but I couldn’t connect via ssh.

I then tried to create the image several times (using rpi-installer), adjusting the accounts in the configuration section without much success.

My current solution is to add my ssh key in the “OS customization → services” settings and of course NOT connect my PI3 to the ethernet network.

This way, the identification procedure via the cell phone takes place as planned in the application.

Now, access to Openhab is correct and the ssh connection doesn’t require a password.

Now I’ll try to install a temperature sensor …

Thank you for this free and beautiful application

well, after many unsuccessful attempts, I’ve just figured out the problem.

Until now, I had used the rasperry RPI-INSTALLER tool to install my SD card.
With various adjustments (set in the configuration interface) I’d managed to get a partially functional system,

Finally I loaded my SD with Balena -Etcher and the thermostat works correctly according to your specifications…

2 posts were split to a new topic: GitLab image generation question

I attempted to run this version on a Raspberry Pi 4, and it did succesfully boot but it won’t read the bme280, it gives me a script error where the readouts should be… I had a previous version fully functioning on a Pi 4 I know.

This is the error.

Traceback (most recent call last): File "/home/pi/scripts/bme280.py", line 182, in <module> main() File "/home/pi/scripts/bme280.py", line 170, in main (chip_id, chip_version) = readBME280ID() File "/home/pi/scripts/bme280.py", line 65, in readBME280ID (chip_id, chip_version) = bus.read_i2c_block_data(addr, REG_ID, 2) OSError: [Errno 121] Remote I/O

The O/S is giving you an I/O error, so it looks like there’s an issue with the bme280 sensor. We had another person report this and it turned out to be a defective Raspberry Pi.

SSH into the pi and run i2cdetect -y 1 and the output should look something like this. You may have additional numbers there, but the important thing is that you should see either 76 or 77 there in that grid.

If neither 76 nor 77 are there, then the issue is that the pi can’t see the sensor. Most likely causes of this include:

  1. Incorrect wiring of the BME280 sensor (see the docs for the pinout)
  2. Defective sensor (replace if you have another)
  3. Defective pi (replace if you have another)

If you have any other i2c devices, that might help you determine if the pi is broken. If it can see other devices, it points more towards the sensor being the issue.

I don’t own a Pi 4, so I’ve never tested on that platform, but others have been reporting success, and the software should be compatible.

Well, turns out that I managed to flip the SDA and SCL wires around… once I wired it correctly it worked immediately!

1 Like